readGltfGraphics Function
Produce a RenderGraphic from a glTF asset suitable for use in view decorations.
readGltfGraphics(args: ReadGltfGraphicsArgs): Promise<RenderGraphic | undefined>
@returns a graphic produced from the glTF asset's default scene, or undefined
if a graphic could not be produced from the asset.
@note Support for the full glTF 2.0 specification is currently a work in progress. If a particular glTF asset fails to load and/or display properly, please submit an issue.
@see - Example decorator for an example of a decorator that reads and displays a glTF asset.
- readGltf to obtain more information about the glTF model.
Parameter | Type | Description |
---|---|---|
args | ReadGltfGraphicsArgs |
Returns - Promise<RenderGraphic | undefined>
a graphic produced from the glTF asset's default scene, or undefined
if a graphic could not be produced from the asset.
Defined in
- core/frontend/src/tile/GltfReader.ts Line 1770
Last Updated: 04 December, 2023