RealityTileTree Class

Base class for a TileTree representing a reality model (e.g., a point cloud or photogrammetry mesh) or 3d terrain with map imagery. The tiles within the tree are instances of RealityTiles.

Extends

Extended by

Inherited methods

Name Inherited from Description
countTiles(): number TileTree Returns the number of Tiles currently in memory belonging to this tree, primarily for debugging.
dispose(): void TileTree Dispose of this tree and any resources owned by it.
getEcefTransform(): Promise<undefined | Transform> TileTree Return the transform from the tile tree's coordinate space to ECEF (Earth Centered Earth Fixed) coordinates.
selectTiles(args: TileDrawArgs): Tile[] TileTree Selects tiles of appropriate resolution for some purpose like drawing to the screen, producing a shadow map, etc.

Properties

Name Type Description
batchTableProperties Accessor ReadOnly undefined | BatchTableProperties The mapping of per-feature JSON properties from this tile tree's batch table, if one is defined.  

Inherited properties

Name Type Inherited from Description
contentRange Readonly undefined | Range3d TileTree Optional tight bounding box around the entire contents of all of this tree's tiles.
expirationTime Readonly BeDuration TileTree The length of time after which tiles belonging to this tree are considered elegible for disposal if they are no longer in use.
id Readonly string TileTree Uniquely identifies this tree among all other tile trees associated with the iModel.
iModel Readonly IModelConnection TileTree  
iModelTransform Readonly Transform TileTree Transform from this tile tree's coordinate space to the iModel's coordinate space.
is2d Accessor ReadOnly boolean TileTree True if this tile tree contains 2d graphics.
isDisposed Accessor ReadOnly boolean TileTree True if TileTree.dispose has been called on this tile tree.
lastSelectedTime Accessor ReadOnly BeTimePoint TileTree The most recent time at which tiles TileTree.selectTiles was called.
modelId Readonly string TileTree A 64-bit identifier for this tile tree, unique within the context of its IModelConnection.
range Accessor ReadOnly Range3d TileTree The volume of space occupied by this tile tree.

Defined in

Last Updated: 16 April, 2024