TileBoundingBoxes Enumeration

Options for displaying tile bounding boxes for debugging purposes.

Bounding boxes are color-coded based on refinement strategy:

  • Blue: A leaf tile (has no child tiles).
  • Green: An ordinary tile (sub-divides into 4 or 8 child tiles).
  • Red: A tile which refines to a single higher-resolution child occupying the same volume.

@see Viewport.debugBoundingBoxes

Members

Name Value Description
Both Display both volume and content boxes.
ChildVolumes Display boxes for direct children, where blue boxes indicate empty volumes.
Content Display boxes representing the range of the tile's contents, which may be tighter than (but never larger than) the tile's full volume.
None Display no bounding boxes
SolidBox Display a transparent solid box representing the tile's full volume.
To be replaced with a separate option that applies to any of the other TileBoundingBoxes modes.
Sphere Display bounding sphere.
Volume Display boxes representing the tile's full volume.

Defined in

Last Updated: 16 April, 2024