constructor Method

Create a new channel.

TileRequestChannel(name: string, concurrency: number): TileRequestChannel

@see TileRequestChannels.getForHttp to create an HTTP-based channel.

Parameter Type Description
name string The unique name of the channel.
concurrency number The maximum number of requests that can be dispatched and awaiting a response at any given time. Requests beyond this maximum are enqueued for deferred dispatch.

Returns - TileRequestChannel

Defined in

Last Updated: 16 April, 2024