syncToolSettingsProperties Method

Called by tool to synchronize the UI with property changes made by tool. This is typically used to provide user feedback during tool dynamics. If the syncData contains a quantity value and if the displayValue is not defined, the displayValue will be generated in the UI layer before displaying the value.

syncToolSettingsProperties(syncData: DialogPropertySyncItem[]): void

Parameter Type Description
syncData DialogPropertySyncItem[]  

Returns - void

Defined in

Last Updated: 16 April, 2024