DepthPointOptions Interface

Options to control behavior of Viewport.pickDepthPoint.

Properties

Name Type Description
excludeDecorations undefined | boolean If true, geometry from pickable decorations will not be selected.  
excludeExternalIModels undefined | boolean If true, geometry from an IModelConnection other than the one associated with the Viewport will not be selected.  
excludeNonLocatable undefined | boolean If true, geometry with the "non-locatable" flag set will not be selected.  

Defined in

Last Updated: 16 April, 2024