changeMapLayerProps Method

Modify a subset of a map layer settings.

changeMapLayerProps(props: Partial<MapLayerProps>, mapLayerIndex: MapLayerIndex): void

Parameter Type Description
props Partial<MapLayerProps> props JSON representation of the properties to change. Any properties not present will retain their current values.
mapLayerIndex MapLayerIndex the MapLayerIndex where the map layer should be inserted.

Example that changes only the visibility of the first overlay map layer.
ts<br> style.changeMapLayerProps({ visible: false }, 0, false);<br>

Returns - void

Defined in

Last Updated: 16 April, 2024