MarkerSet<T extends Marker> Class

A set of Markers that are logically related, such that they cluster when they overlap one another in screen space. In that case, a cluster marker is drawn instead of the overlapping Markers.

Methods

Name Description
constructor<T extends Marker<T>>(viewport?: ScreenViewport): MarkerSet<T> Construct a new MarkerSet for a specific ScreenViewport.  
addDecoration(context: DecorateContext): void This method should be called from Decorator.decorate.  
changeViewport(viewport: ScreenViewport): void Change the ScreenViewport for this MarkerSet.  
getClusterMarker(cluster: Cluster<T>): Marker ProtectedAbstract Implement this method to create a new Marker that is shown as a stand-in for a Cluster of Markers that overlap one another.  
getMinScaleViewW(vp: Viewport): number Get weight value limit establishing the distance from camera for the back of view scale factor.  
markDirty(): void Indicate that this MarkerSet has been changed and is now dirty.  

Properties

Name Type Description
clusterRadius Protected number The radius (in pixels) representing the distance between the screen X,Y positions of two Markers to be clustered.  
markers Accessor ReadOnly Set<T> The set of Markers in this MarkerSet.  
minimumClusterSize number The minimum number of Markers that must overlap before they are clustered.  
viewport Accessor ReadOnly undefined | ScreenViewport The ScreenViewport of this MarkerSet.  

Defined in

Last Updated: 15 March, 2024