addDecorator Method
Add a new Decorator to display decorations into the active views.
addDecorator(decorator: Decorator): () => void
@throws Error if decorator is already active.
@returns a function that may be called to remove this decorator (in lieu of calling ViewManager.dropDecorator.)
@see ViewManager.dropDecorator
Parameter | Type | Description |
---|---|---|
decorator | Decorator | The new decorator to add. |
Returns - () => void
a function that may be called to remove this decorator (in lieu of calling ViewManager.dropDecorator.)
Defined in
- core/frontend/src/ViewManager.ts Line 483
Last Updated: 04 December, 2023