setAntialiasingAllViews Method

Sets the number of MSAA samples for all currently- and subsequently-opened ScreenViewports.

setAntialiasingAllViews(numSamples: number): void

@see Viewport.antialiasSamples to adjust the number of samples for a specific viewport.

Parameter Type Description
numSamples number The number of samples as a power of two. Values of 1 or less indicates anti-aliasing should be disabled. Non-power-of-two values are rounded
down to the nearest power of two. The maximum number of samples supported depends upon the client's graphics hardware capabilities. Higher values produce
a higher-quality image but also may also reduce framerate.

Returns - void

Defined in

Last Updated: 16 April, 2024