continuousRendering

Accessor

Enables or disables continuous rendering. Ideally, during each render frame a Viewport will do as little work as possible. To make that possible, the viewport keeps track of what has changed about its internal state from one frame to the next. For example, if the view frustum has not changed since the previous frame, it is likely that the viewport does not need to be re-rendered at all.

In some circumstances, it is desirable to bypass the logic that limits the amount of work performed each frame. A primary example is a viewport that has some animations applied to it, or when diagnostic information like frames-per-second is being monitored.

continuousRendering: boolean

@note An application which enables continuous rendering should disable it as soon as it is no longer needed.

Returns - boolean


Setter

continuousRendering(contRend: boolean): void

Parameter Type Description
contRend boolean  

Returns - void

Defined in

Last Updated: 15 March, 2024