lookAtGlobalLocation Method

Look at a global location, placing the camera's eye at the specified eye height above a viewed location. If location is defined, its center position will be viewed using the specified eye height. If location also has an area specified, the eye height will be adjusted to view the specified location based on that area. Otherwise, this function views a point on the earth as if the current eye point was placed on the earth. If the eyePoint parameter is defined, instead this point will be placed on the earth and viewed. Specify pitchAngleRadians to tilt the final view; this defaults to 0. Returns the distance from original eye point to new eye point.

lookAtGlobalLocation(eyeHeight: number, pitchAngleRadians: number = 0, location?: GlobalLocation, eyePoint?: Point3d): number

Parameter Type Description
eyeHeight number  
pitchAngleRadians number  
location GlobalLocation  
eyePoint Point3d  

Returns - number

Defined in

Last Updated: 16 April, 2024