setupFromFrustum Method

Initialize the origin, extents, and rotation from an existing Frustum This function is commonly used in the implementation of ViewTools as follows:

  1. Obtain the ViewState's initial frustum.
  2. Modify the frustum based on user input.
  3. Update the ViewState to match the modified frustum.

setupFromFrustum(frustum: Frustum, opts?: OnViewExtentsError): ViewStatus

@returns Success if the frustum was successfully updated, or an appropriate error code.

Parameter Type Description
frustum Frustum  
opts OnViewExtentsError for providing onExtentsError

Returns - ViewStatus

Success if the frustum was successfully updated, or an appropriate error code.

Defined in

Last Updated: 15 March, 2024