SweepContour Class

Sweepable planar contour with Transform for local to world interaction.

  • The surface/solid classes LinearSweep, RotationalSweep, RuledSweep use this for their swept contours.

Methods

Name Description
announceFacets(announce: (facets: IndexedPolyface) => void, options?: StrokeOptions): void Emit facets to a function  
buildFacets(options?: StrokeOptions): void Build the (cached) internal facets for the contour.  
clone(): SweepContour Return a deep clone.  
cloneTransformed(transform: Transform): undefined | SweepContour Return a transformed clone.  
computeXYStrokes(options?: StrokeOptions): void Recompute the local strokes cache for this contour  
emitFacets(builder: PolyfaceBuilder, reverse: boolean, transform?: Transform): void Emit facets to a builder.  
getCurves(): CurveCollection Return (Reference to) the curves  
isAlmostEqual(other: any): boolean Test for near equality of curves, frame, and axis.  
purgeFacets(): void Delete facet cache.  
sweepToUnionOfConvexClipPlaneSets(sweepVector?: Vector3d, cap0: boolean = false, cap1: boolean = false, options?: StrokeOptions): undefined | UnionOfConvexClipPlaneSets Create a UnionOfConvexClipPlaneSets that clips to the swept faceted contour region.  
tryTransformInPlace(transform: Transform): boolean Apply transform to the curves, axis.  
createForLinearSweep(contour: AnyCurve, defaultNormal?: Vector3d): undefined | SweepContour Static Create for linear sweep.  
createForPolygon(points: MultiLineStringDataVariant, defaultNormal?: Vector3d): undefined | SweepContour Static Create for linear sweep.  
createForRotation(contour: AnyCurve, axis: Ray3d): undefined | SweepContour Static Create for rotational sweep.  

Properties

Name Type Description
axis undefined | Ray3d Axis used only in rotational case.  
curves CurveCollection The underlying curve collection, in its world coordinates position.  
localToWorld Transform coordinate frame that in which the curves are all in the xy plane.  
xyStrokes Accessor ReadOnly undefined | CurveCollection Return cached contour strokes  

Defined in

Last Updated: 16 April, 2024