EditCommand Class

An EditCommand performs an editing action on the backend. EditCommands are usually paired with and driven by EditTools on the frontend. EditCommands have a commandId that uniquely identifies them, so they can be found via a lookup in the EditCommandAdmin. Each EditCommand must be registered in the EditCommandAdmin with EditCommandAdmin.register or EditCommandAdmin.registerModule. Every time an EditCommand runs, a new instance of (a subclass of) this class is created.

Extended by

Implements

Methods

Name Description
constructor(iModel: IModelDb, ..._args: any[]): EditCommand    
onStart(): Promise<any>    
ping(): Promise<{ commandId: string, version: string }>    
requestFinish(): Promise<string> Called when another EditCommand wishes to become the active EditCommand.  

Properties

Name Type Description
commandId Static string The unique string that identifies this EditCommand class.  
ctor Accessor ReadOnly undefined    
iModel Readonly IModelDb The iModel this EditCommand may modify.  
version Static string    

Defined in

Last Updated: 16 April, 2024