CompileShadersTool Class

Compiles all registered shader programs for which compilation has not already been attempted. This is useful for uncovering/debugging platform-specific shader issues.

Extends

Methods

Name Description
constructor(..._args: any[]): CompileShadersTool    
execute(control: RenderSystemDebugControl): void    

Inherited methods

Name Inherited from Description
parseAndRun(..._args: string[]): Promise<boolean> RenderSystemDebugControlTool Run this instance of a tool using a series of string arguments.
run(_args: any[]): Promise<boolean> RenderSystemDebugControlTool  
register(namespace?: string): void Static RenderSystemDebugControlTool Register this Tool class with the ToolRegistry.

Properties

Name Type Description
toolId Static string The unique string that identifies this tool.  

Inherited properties

Name Type Inherited from Description
description Accessor ReadOnly string RenderSystemDebugControlTool Get the localized description string from this Tool's class
description Accessor StaticReadOnly string RenderSystemDebugControlTool Get the localized description for this Tool class. This returns the value of "tools." + this.toolId + ".description" from
its registered Namespace (e.g. "en/MyApp.json"). If that key is not in the localization namespace,
RenderSystemDebugControlTool.flyover is returned.
englishKeyin Accessor StaticReadOnly string RenderSystemDebugControlTool Get the English keyin string for this Tool class. This returns the value of "tools." + this.toolId + ".keyin" from
its registered Namespace (e.g. "en/MyApp.json").
flyover Accessor ReadOnly string RenderSystemDebugControlTool Get the localized flyover string from this Tool's class
flyover Accessor StaticReadOnly string RenderSystemDebugControlTool Get the localized flyover for this Tool class. This returns the value of "tools." + this.toolId + ".flyover" from
its registered Namespace (e.g. "en/MyApp.json"). If that key is not in the localization namespace,
RenderSystemDebugControlTool.keyin is returned.
hidden Static boolean RenderSystemDebugControlTool If true, this Tool will not appear in the list from getToolList.
iconSpec Accessor ReadOnly string RenderSystemDebugControlTool Get the iconSpec from this Tool's class.
iconSpec Static string RenderSystemDebugControlTool The icon for this Tool.
keyin Accessor ReadOnly string RenderSystemDebugControlTool Get the localized keyin string from this Tool's class
keyin Accessor StaticReadOnly string RenderSystemDebugControlTool Get the localized keyin string for this Tool class. This returns the value of "tools." + this.toolId + ".keyin" from
its registered Namespace (e.g. "en/MyApp.json").
maxArgs Accessor StaticReadOnly undefined | number RenderSystemDebugControlTool The maximum number of arguments allowed by RenderSystemDebugControlTool.parseAndRun, or undefined if there is no maximum.
If subclasses override RenderSystemDebugControlTool.parseAndRun, they should also override this method to indicate the maximum
number of arguments their implementation expects.
minArgs Accessor StaticReadOnly number RenderSystemDebugControlTool The minimum number of arguments allowed by RenderSystemDebugControlTool.parseAndRun. If subclasses override RenderSystemDebugControlTool.parseAndRun, they should also
override this method to indicate the minimum number of arguments their implementation expects. UI controls can use
this information to ensure the tool has enough information to execute.
namespace Static string RenderSystemDebugControlTool The namespace that provides localized strings for this Tool.
toolId Accessor ReadOnly string RenderSystemDebugControlTool Get the toolId string for this Tool class. This string is used to identify the Tool in the ToolRegistry and is used to localize
the keyin, description, etc. from the current locale.

Defined in

Last Updated: 15 March, 2024