IsolateSelectedElementsTool Class

Isolate all selected elements so that only those elements will be drawn.

Extends

Methods

Name Description
constructor(..._args: any[]): IsolateSelectedElementsTool    
execute(emph: EmphasizeElements, vp: ScreenViewport): void    

Inherited methods

Name Inherited from Description
parseAndRun(..._args: string[]): Promise<boolean> EmphasizeElementsTool Run this instance of a tool using a series of string arguments.
run(_args: any[]): Promise<boolean> EmphasizeElementsTool  
register(namespace?: string): void Static EmphasizeElementsTool Register this Tool class with the ToolRegistry.

Properties

Name Type Description
toolId Static string The unique string that identifies this tool.  

Inherited properties

Name Type Inherited from Description
_wantClear Accessor ProtectedReadOnly boolean EmphasizeElementsTool  
_wantCreate Accessor ProtectedReadOnly boolean EmphasizeElementsTool  
description Accessor ReadOnly string EmphasizeElementsTool Get the localized description string from this Tool's class
description Accessor StaticReadOnly string EmphasizeElementsTool Get the localized description for this Tool class. This returns the value of "tools." + this.toolId + ".description" from
its registered Namespace (e.g. "en/MyApp.json"). If that key is not in the localization namespace,
EmphasizeElementsTool.flyover is returned.
englishKeyin Accessor StaticReadOnly string EmphasizeElementsTool Get the English keyin string for this Tool class. This returns the value of "tools." + this.toolId + ".keyin" from
its registered Namespace (e.g. "en/MyApp.json").
flyover Accessor ReadOnly string EmphasizeElementsTool Get the localized flyover string from this Tool's class
flyover Accessor StaticReadOnly string EmphasizeElementsTool Get the localized flyover for this Tool class. This returns the value of "tools." + this.toolId + ".flyover" from
its registered Namespace (e.g. "en/MyApp.json"). If that key is not in the localization namespace,
EmphasizeElementsTool.keyin is returned.
hidden Static boolean EmphasizeElementsTool If true, this Tool will not appear in the list from getToolList.
iconSpec Accessor ReadOnly string EmphasizeElementsTool Get the iconSpec from this Tool's class.
iconSpec Static string EmphasizeElementsTool The icon for this Tool.
keyin Accessor ReadOnly string EmphasizeElementsTool Get the localized keyin string from this Tool's class
keyin Accessor StaticReadOnly string EmphasizeElementsTool Get the localized keyin string for this Tool class. This returns the value of "tools." + this.toolId + ".keyin" from
its registered Namespace (e.g. "en/MyApp.json").
maxArgs Accessor StaticReadOnly undefined | number EmphasizeElementsTool The maximum number of arguments allowed by EmphasizeElementsTool.parseAndRun, or undefined if there is no maximum.
If subclasses override EmphasizeElementsTool.parseAndRun, they should also override this method to indicate the maximum
number of arguments their implementation expects.
minArgs Accessor StaticReadOnly number EmphasizeElementsTool The minimum number of arguments allowed by EmphasizeElementsTool.parseAndRun. If subclasses override EmphasizeElementsTool.parseAndRun, they should also
override this method to indicate the minimum number of arguments their implementation expects. UI controls can use
this information to ensure the tool has enough information to execute.
namespace Static string EmphasizeElementsTool The namespace that provides localized strings for this Tool.
toolId Accessor ReadOnly string EmphasizeElementsTool Get the toolId string for this Tool class. This string is used to identify the Tool in the ToolRegistry and is used to localize
the keyin, description, etc. from the current locale.

Defined in

Last Updated: 15 March, 2024