RenderTargetDebugControlToggleTool Class

Toggles some aspect of a RenderTargetDebugControl for the selected viewport.

Extends

Extended by

Methods

Name Description
constructor(..._args: any[]): RenderTargetDebugControlToggleTool    
execute(control: RenderTargetDebugControl, vp: ScreenViewport): void Protected    
parseAndRun(...args: string[]): Promise<boolean> Run this instance of a tool using a series of string arguments.  

Inherited methods

Name Inherited from Description
run(_args: any[]): Promise<boolean> RenderTargetDebugControlTool  
register(namespace?: string): void Static RenderTargetDebugControlTool Register this Tool class with the ToolRegistry.

Properties

Name Type Description
aspect Accessor ProtectedAbstractReadOnly DebugControlBoolean    
maxArgs Accessor StaticReadOnly number The maximum number of arguments allowed by RenderTargetDebugControlToggleTool.parseAndRun, or undefined if there is no maximum.  
minArgs Accessor StaticReadOnly number The minimum number of arguments allowed by RenderTargetDebugControlToggleTool.parseAndRun.  

Inherited properties

Name Type Inherited from Description
description Accessor ReadOnly string RenderTargetDebugControlTool Get the localized description string from this Tool's class
description Accessor StaticReadOnly string RenderTargetDebugControlTool Get the localized description for this Tool class. This returns the value of "tools." + this.toolId + ".description" from
its registered Namespace (e.g. "en/MyApp.json"). If that key is not in the localization namespace,
RenderTargetDebugControlTool.flyover is returned.
englishKeyin Accessor StaticReadOnly string RenderTargetDebugControlTool Get the English keyin string for this Tool class. This returns the value of "tools." + this.toolId + ".keyin" from
its registered Namespace (e.g. "en/MyApp.json").
flyover Accessor ReadOnly string RenderTargetDebugControlTool Get the localized flyover string from this Tool's class
flyover Accessor StaticReadOnly string RenderTargetDebugControlTool Get the localized flyover for this Tool class. This returns the value of "tools." + this.toolId + ".flyover" from
its registered Namespace (e.g. "en/MyApp.json"). If that key is not in the localization namespace,
RenderTargetDebugControlTool.keyin is returned.
hidden Static boolean RenderTargetDebugControlTool If true, this Tool will not appear in the list from getToolList.
iconSpec Accessor ReadOnly string RenderTargetDebugControlTool Get the iconSpec from this Tool's class.
iconSpec Static string RenderTargetDebugControlTool The icon for this Tool.
keyin Accessor ReadOnly string RenderTargetDebugControlTool Get the localized keyin string from this Tool's class
keyin Accessor StaticReadOnly string RenderTargetDebugControlTool Get the localized keyin string for this Tool class. This returns the value of "tools." + this.toolId + ".keyin" from
its registered Namespace (e.g. "en/MyApp.json").
namespace Static string RenderTargetDebugControlTool The namespace that provides localized strings for this Tool.
toolId Accessor ReadOnly string RenderTargetDebugControlTool Get the toolId string for this Tool class. This string is used to identify the Tool in the ToolRegistry and is used to localize
the keyin, description, etc. from the current locale.
toolId Static string RenderTargetDebugControlTool The unique string that identifies this tool.

Defined in

Last Updated: 16 April, 2024