TestClipStyleTool Class

Simple tool that toggles a hard-coded clip style overriding various aspects of the cut geometry appearance.

Extends

Methods

Name Description
constructor(..._args: any[]): TestClipStyleTool    
execute(vp: Viewport): Promise<boolean> Protected    
parse(args: string[]): Promise<boolean> Protected    

Inherited methods

Name Inherited from Description
parseAndRun(...args: string[]): Promise<boolean> DisplayStyleTool  
run(): Promise<boolean> DisplayStyleTool  
register(namespace?: string): void Static DisplayStyleTool Register this Tool class with the ToolRegistry.

Properties

Name Type Description
maxArgs Accessor StaticReadOnly number The maximum number of arguments allowed by TestClipStyleTool.parseAndRun, or undefined if there is no maximum.  
minArgs Accessor StaticReadOnly number The minimum number of arguments allowed by TestClipStyleTool.parseAndRun.  
require3d Accessor ProtectedReadOnly boolean    
toolId Static string The unique string that identifies this tool.  

Inherited properties

Name Type Inherited from Description
description Accessor ReadOnly string DisplayStyleTool Get the localized description string from this Tool's class
description Accessor StaticReadOnly string DisplayStyleTool Get the localized description for this Tool class. This returns the value of "tools." + this.toolId + ".description" from
its registered Namespace (e.g. "en/MyApp.json"). If that key is not in the localization namespace,
DisplayStyleTool.flyover is returned.
englishKeyin Accessor StaticReadOnly string DisplayStyleTool Get the English keyin string for this Tool class. This returns the value of "tools." + this.toolId + ".keyin" from
its registered Namespace (e.g. "en/MyApp.json").
flyover Accessor ReadOnly string DisplayStyleTool Get the localized flyover string from this Tool's class
flyover Accessor StaticReadOnly string DisplayStyleTool Get the localized flyover for this Tool class. This returns the value of "tools." + this.toolId + ".flyover" from
its registered Namespace (e.g. "en/MyApp.json"). If that key is not in the localization namespace,
DisplayStyleTool.keyin is returned.
hidden Static boolean DisplayStyleTool If true, this Tool will not appear in the list from getToolList.
iconSpec Accessor ReadOnly string DisplayStyleTool Get the iconSpec from this Tool's class.
iconSpec Static string DisplayStyleTool The icon for this Tool.
keyin Accessor ReadOnly string DisplayStyleTool Get the localized keyin string from this Tool's class
keyin Accessor StaticReadOnly string DisplayStyleTool Get the localized keyin string for this Tool class. This returns the value of "tools." + this.toolId + ".keyin" from
its registered Namespace (e.g. "en/MyApp.json").
namespace Static string DisplayStyleTool The namespace that provides localized strings for this Tool.
toolId Accessor ReadOnly string DisplayStyleTool Get the toolId string for this Tool class. This string is used to identify the Tool in the ToolRegistry and is used to localize
the keyin, description, etc. from the current locale.

Defined in

Last Updated: 15 March, 2024