QuantityNumberInputProps Interface

Properties for the QuantityNumberInput component

Extends

  • Omit<InputProps, "value" | "min" | "max" | "step" | "onFocus" | "onChange">

Properties

Name Type Description
containerClassName string | undefined CSS class name for the QuantityNumberInput component container div  
max number | undefined number or function defaults to Number.MAX_SAFE_INTEGER  
min number | undefined number or function Number.MIN_SAFE_INTEGER  
onChange (value: number) => void | undefined    
persistenceValue number | undefined Initial magnitude in 'persistence' units.  
quantityType QuantityTypeArg Type of quantity being input.  
ref Ref<HTMLInputElement> | undefined Provides ability to return reference to HTMLInputElement  
showTouchButtons boolean | undefined if true up/down buttons are shown larger and side by side  
snap boolean | undefined Set to true to "snap" to the closest step value while incrementing or decrementing (up/down buttons or arrow keys).  
step StepFunctionProp | undefined increment step value used while incrementing or decrementing (up/down buttons or arrow keys) defaults to 1.  

Defined in

Last Updated: 13 May, 2024