BaseQuantityDescription Class

Beta  

Base Quantity Property Description

Implements

Methods

Name Description
constructor(name: string, displayLabel: string, iconSpec?: string): BaseQuantityDescription    
format(numberValue: number): string    
formatValue(numberValue: number): string ProtectedAbstract    
parse(userInput: string): ParseResults    
parseString(userInput: string): ParseResults ProtectedAbstract    

Properties

Name Type Description
displayLabel string Display label for the property description  
editor PropertyEditorInfo Information for a property editor  
name string Name of the property description  
parseError Accessor AbstractReadOnly string    
quantityType Accessor AbstractReadOnly string Quantity type key used to look up formatting and parsing specs.  
typename string Type name used to determine applicable Type Converter and Property Editor  

Defined in

Last Updated: 20 June, 2023