ItemProps Interface

Beta  

Deprecated  in 3.0. Use ToolbarButtonItemProps instead.

Properties of Item component.

Extends

Methods

Name Description
onClick(): void Optional Function called when the item is clicked.  
onKeyDown(e: KeyboardEvent<Element>): void Optional Function called when a key is pressed.  
onSizeKnown(size: SizeProps): void Optional Function called when size is known.  

Properties

Name Type Description
badge undefined | ReactNode A badge to draw.  
icon undefined | ReactNode button icon.  
isActive undefined | boolean Describes if item is active.  
isDisabled undefined | boolean Describes if the item is disabled.  
title undefined | string Title for the item.  

Inherited properties

Name Type Inherited from Description
className undefined | string CommonProps Custom CSS class name
itemId undefined | string CommonProps Optional unique identifier for item.
style undefined | CSSProperties CommonProps Custom CSS style properties

Defined in

Last Updated: 20 June, 2023