BackstageItemProps Interface

Deprecated  in 3.0. Use BackstageItem instead

Base properties for a Backstage item.

Extends

Methods

Name Description
stateFunc(state: Readonly<BackstageItemState>): BackstageItemState Optional optional function to set state of backstage item  

Properties

Name Type Description
description string | StringGetter if set, it is used to explicitly set the description shown by a component.  
descriptionKey undefined | string if set, it is used to define a key that is used to look up a localized string.  
isActive undefined | boolean if set, component will be shown with as the active item - defaults to false  
isEnabled undefined | boolean if set, component will be enabled - defaults to true  
label string | StringGetter if set, it is used to explicitly set the label shown by a component.  
labelKey undefined | string if set, it is used to define a key that is used to look up a localized string.  
stateSyncIds undefined | string[] optional SyncUi event ids that will trigger the state function to run.  
tooltip string | StringGetter used to explicitly set the tooltip shown by a component.  
tooltipKey undefined | string if set, it is used to define a key that is used to look up a localized string.  

Inherited properties

Name Type Inherited from Description
className undefined | string IconProps Custom CSS class name
iconSpec undefined | IconSpec IconProps CSS class name or SvgSprite/SvgPath for icon.
itemId undefined | string IconProps Optional unique identifier for item.
style undefined | CSSProperties IconProps Custom CSS style properties

Defined in

Last Updated: 20 June, 2023