Backstage Class

Deprecated  in 3.6. Use BackstageComposer instead.

Backstage React component.

Extends

Methods

Name Description
constructor(props: BackstageProps): Backstage    
componentDidMount(): void    
componentDidUpdate(prevProps: BackstageProps): void    
componentWillUnmount(): void    
render(): ReactNode    
getBackstageToggleCommand(overrideIconSpec?: IconSpec): CommandItemDef Static Get CommandItemDef that will toggle display of Backstage and allow iconSpec to be overridden  
hide(): void Static Hides the Backstage  
show(): void Static Shows the Backstage  

Properties

Name Type Description
backstageToggleCommand Accessor StaticReadOnly CommandItemDef Command that toggles the Backstage  
isBackstageVisible Static boolean    
onBackstageEvent StaticReadonly BackstageEvent    

Defined in

Last Updated: 20 June, 2023