ChildWindowManager Class

Deprecated  in 3.7. Use UiFramework.childWindows property to access.

Supports opening a child browser window from the main application window. The child window is managed by the main application and is running in the same security context. The application must deliver the html file iTwinPopup.html along side its index.html. See also: Child Window Manager

Methods

Name Description
constructor(): ChildWindowManager    
close(childWindowId: string, processWindowClose: boolean = true): boolean Close a specific child window.  
closeAll(): void Close all child/pop-out windows.  
closeAllChildWindows(): void Close all child/pop-out windows. Deprecated  
closeChildWindow(childWindowId: string, processWindowClose: boolean = true): boolean   Deprecated  
find(childWindowId: undefined | string): undefined | OpenChildWindowInfo Returns the OpenChildWindowInfo for the related id.  
findChildWindow(childWindowId: undefined | string): undefined | OpenChildWindowInfo   Deprecated  
findChildWindowId(contentWindow: undefined | | Window): undefined | string   Deprecated  
findId(contentWindow: undefined | | Window): undefined | string Return the childWindowId of the provided window.  
open(childWindowId: string, title: string, content: ReactNode, location: ChildWindowLocationProps, useDefaultPopoutUrl?: boolean): boolean Open a new child window.  
openChildWindow(childWindowId: string, title: string, content: ReactNode, location: ChildWindowLocationProps, useDefaultPopoutUrl?: boolean): boolean   Deprecated  

Properties

Name Type Description
openChildWindows Accessor ReadOnly OpenChildWindowInfo[]    

Defined in

Last Updated: 20 June, 2023