ContentDialogManager Class

Deprecated  in 3.7. Use UiFramework.content.dialog property.

Content Dialog Manager class displays and manages multiple modeless dialogs

Methods

Name Description
constructor(): ContentDialogManager    
closeDialog(id: string): void Static Close a modeless dialog  
getDialogInfo(id: string): undefined | ContentDialogInfo Static    
getDialogZIndex(id: string): number Static Get the z-index for a modeless dialog  
handlePointerDownEvent(_event: PointerEvent<Element>, id: string, updateFunc: () => void): void Static Handle a pointer down event on a modeless dialog  
initialize(): void Static Initialize the modeless dialog manager. Deprecated  
openDialog(dialog: ReactNode, id: string, parentDocument: Document = document): void Static Open a modeless dialog  
update(): void Static Update the dialogs  

Properties

Name Type Description
activeDialog Accessor StaticReadOnly ReactNode Get the active modeless dialog  
dialogCount Accessor StaticReadOnly number Get the count of modeless dialogs  
dialogs Accessor StaticReadOnly DialogInfo[] Get the array of modeless dialogs  
onContentDialogChangedEvent Accessor StaticReadOnly ContentDialogChangedEvent Content Dialog Changed Event  

Defined in

Last Updated: 20 June, 2023