FrontstageProvider Class

Provides a definition required to create a Frontstage.

Extended by

Methods

Name Description
constructor(): FrontstageProvider    
frontstageConfig(): FrontstageConfig Optional Return the frontstage configuration. Beta  

Properties

Name Type Description
frontstage Accessor AbstractReadOnly ReactElement<FrontstageProps, string | JSXElementConstructor<any>> Return an element that describes a frontstage.  
id Accessor AbstractReadOnly string Get the Frontstage React based definition  

Defined in

Last Updated: 20 June, 2023