StagePanelDef Class

A StagePanelDef represents each Stage Panel within a Frontstage.

Extends

Methods

Name Description
constructor(): StagePanelDef Constructor for PanelDef.  

Inherited methods

Name Inherited from Description
addWidgetDef(widgetDef: WidgetDef): void WidgetHost Adds a WidgetDef to the list of Widgets.
findWidgetDef(id: string): undefined | WidgetDef WidgetHost Finds a WidgetDef with a given Id.
getSingleWidgetDef(): undefined | WidgetDef WidgetHost If there is only one Widget in the Panel, gets the single WidgetDef.

Properties

Name Type Description
applicationData Accessor ReadOnly any Any application data to attach to this Panel.  
location Accessor ReadOnly StagePanelLocation Location of panel.  
panelState Accessor StagePanelState Panel state.  
pinned Accessor ReadOnly boolean Indicates whether the panel is pinned.  
resizable Accessor ReadOnly boolean Indicates whether the panel is resizable.  
size Accessor undefined | number Default size of the panel  
widgetDefs Accessor ReadOnly undefined Gets the list of Widgets.  

Inherited properties

Name Type Inherited from Description
widgetCount Accessor ReadOnly number WidgetHost Gets the number of Widgets.

Defined in

Last Updated: 20 June, 2023