StagePanelProps Interface

Deprecated  in 3.5. Props of a deprecated component.

Properties of a StagePanel component

Properties

Name Type Description
allowedZones undefined | ZoneLocation[] Describes which zones are allowed in this stage panel.  
applicationData undefined | any Any application data to attach to this Panel.  
defaultState undefined | StagePanelState Default Panel state.  
header undefined | ReactNode Stage panel header.  
maxSize undefined | StagePanelMaxSizeSpec Maximum size of the panel.  
minSize undefined | number Minimum size of the panel.  
panelZones undefined | StagePanelZonesProps Properties for the Panel Zones in this Panel. Beta  
pinned undefined | boolean Indicates whether the panel is pinned.  
resizable boolean Indicates whether the panel is resizable.  
size undefined | number Default size of the panel.  
widgets undefined | ReactElement<WidgetProps, string | JSXElementConstructor<any>>[] Properties for the Widgets in this Panel.  

Defined in

Last Updated: 20 June, 2023