StagePanel Class

Deprecated  in 3.6. Use StagePanelConfig instead.

Frontstage Panel React component.

Extends

Methods

Name Description
constructor(props: StagePanelProps): StagePanel    
componentDidMount(): void    
componentDidUpdate(prevProps: StagePanelProps): void    
componentWillUnmount(): void    
render(): ReactNode    
initializeStagePanelDef(panelDef: StagePanelDef, props: StagePanelProps, panelLocation: StagePanelLocation): void Static    

Properties

Name Type Description
defaultProps StaticReadonly StagePanelDefaultProps    

Defined in

Last Updated: 20 June, 2023