StandardStatusbarItemsProvider Class

Provide standard statusbar fields for the SimpleStatusbarWidget

Extends

  • BaseUiItemsProvider

Methods

Name Description
constructor(providerId: string, _defaultItems?: DefaultStatusbarItems, isSupportedStage?: (stageId: string, stageUsage: string, stageAppData?: any) => boolean): StandardStatusbarItemsProvider    
provideStatusBarItemsInternal(_stageId: string, _stageUsage: string, _stageAppData?: any): CommonStatusBarItem[]    
register(providerId: string, defaultItems?: DefaultStatusbarItems, isSupportedStage?: (stageId: string, stageUsage: string, stageAppData?: any) => boolean): StandardStatusbarItemsProvider Static static function to register the StandardStatusbarItemsProvider  

Inherited methods

Name Inherited from Description
onUnregister(): void BaseUiItemsProvider  
provideBackstageItems(): BackstageItem[] BaseUiItemsProvider Backstage items are not stage specific so no callback is used
provideStatusBarItems(stageId: string, stageUsage: string, stageAppData?: any): CommonStatusBarItem[] BaseUiItemsProvider  
provideToolbarButtonItems(stageId: string, stageUsage: string, toolbarUsage: ToolbarUsage, toolbarOrientation: ToolbarOrientation, stageAppData?: any): CommonToolbarItem[] BaseUiItemsProvider  
provideToolbarButtonItemsInternal(_stageId: string, _stageUsage: string, _toolbarUsage: ToolbarUsage, _toolbarOrientation: ToolbarOrientation, _stageAppData?: any): CommonToolbarItem[] BaseUiItemsProvider  
provideWidgets(stageId: string, stageUsage: string, location: StagePanelLocation, section?: StagePanelSection, _zoneLocation?: AbstractZoneLocation, stageAppData?: any): undefined BaseUiItemsProvider  
provideWidgetsInternal(_stageId: string, _stageUsage: string, _location: StagePanelLocation, _section?: StagePanelSection, _zoneLocation?: AbstractZoneLocation, _stageAppData?: any): AbstractWidgetProps[] BaseUiItemsProvider  
unregister(): void BaseUiItemsProvider  

Inherited properties

Name Type Inherited from Description
_providerId Protected string BaseUiItemsProvider  
id Accessor ReadOnly string BaseUiItemsProvider  
isSupportedStage undefined | (stageId: string, stageUsage: string, stageAppData?: any, provider?: UiItemsProvider) => boolean BaseUiItemsProvider  

Defined in

Last Updated: 20 June, 2023