StatusBarItemsManager Class

Deprecated  in 1.x. Use StatusBarItemsManager instead

Beta  

StatusBar Items Manager class.

Extends

Methods

Name Description
constructor(items?: undefined): StatusBarItemsManager    

Inherited methods

Name Inherited from Description
add(itemOrItems: CommonStatusBarItem | ): void UIA_StatusBarItemsManager  
refreshAffectedItems(eventIds: Set<string>): void UIA_StatusBarItemsManager  
remove(itemIdOrItemIds: string | ): void UIA_StatusBarItemsManager Remove StatusBar items based on id
getSyncIdsOfInterest(items: undefined): string[] Static UIA_StatusBarItemsManager  

Inherited properties

Name Type Inherited from Description
items Accessor undefined UIA_StatusBarItemsManager Get an array of the StatusBar items

Defined in

Last Updated: 20 June, 2023