StatusBarLabelIndicatorProps Interface

Beta  

Properties of StatusBarLabelIndicator component.

Extends

Inherited methods

Name Inherited from Description
onClick(): void Optional Omit Function called when indicator is clicked.

Properties

Name Type Description
iconSpec undefined | IconSpec Specification of an icon.  
label undefined | string Indicator label.  
labelSide undefined | StatusBarLabelSide Side to display label.  

Inherited properties

Name Type Inherited from Description
className undefined | string Omit Custom CSS class name
defaultIsOpen undefined | boolean Omit Default state of an indicator popup.
itemId undefined | string Omit Optional unique identifier for item.
popup undefined | ReactNode Omit Content to display in a popup when indicator is clicked.
style undefined | CSSProperties Omit Custom CSS style properties
title undefined | string Omit Title of an indicator.

Defined in

Last Updated: 20 June, 2023