BaseUiItemsProvider Class

Beta  

Base implementation of a UiItemsProvider. The base class allows the user to pass in a function that is used to determine if the active stage should be provided items. Derived provider classes should override the xxxInternal methods to provide items.

Extends

  • BaseUiItemsProvider

Methods

Name Description
constructor(_providerId: string, isSupportedStage?: (stageId: string, stageUsage: string, stageAppData?: any, provider?: UiItemsProvider) => boolean): BaseUiItemsProvider    

Inherited methods

Name Inherited from Description
onUnregister(): void UIA_BaseUiItemsProvider  
provideBackstageItems(): BackstageItem[] UIA_BaseUiItemsProvider Backstage items are not stage specific so no callback is used
provideStatusBarItems(stageId: string, stageUsage: string, stageAppData?: any): CommonStatusBarItem[] UIA_BaseUiItemsProvider  
provideStatusBarItemsInternal(_stageId: string, _stageUsage: string, _stageAppData?: any): CommonStatusBarItem[] UIA_BaseUiItemsProvider  
provideToolbarButtonItems(stageId: string, stageUsage: string, toolbarUsage: ToolbarUsage, toolbarOrientation: ToolbarOrientation, stageAppData?: any): CommonToolbarItem[] UIA_BaseUiItemsProvider  
provideToolbarButtonItemsInternal(_stageId: string, _stageUsage: string, _toolbarUsage: ToolbarUsage, _toolbarOrientation: ToolbarOrientation, _stageAppData?: any): CommonToolbarItem[] UIA_BaseUiItemsProvider  
provideWidgets(stageId: string, stageUsage: string, location: StagePanelLocation, section?: StagePanelSection, _zoneLocation?: AbstractZoneLocation, stageAppData?: any): undefined UIA_BaseUiItemsProvider  
provideWidgetsInternal(_stageId: string, _stageUsage: string, _location: StagePanelLocation, _section?: StagePanelSection, _zoneLocation?: AbstractZoneLocation, _stageAppData?: any): AbstractWidgetProps[] UIA_BaseUiItemsProvider  
unregister(): void UIA_BaseUiItemsProvider  

Inherited properties

Name Type Inherited from Description
_providerId Protected string UIA_BaseUiItemsProvider  
id Accessor ReadOnly string UIA_BaseUiItemsProvider  
isSupportedStage undefined | (stageId: string, stageUsage: string, stageAppData?: any, provider?: UiItemsProvider) => boolean UIA_BaseUiItemsProvider  

Defined in

Last Updated: 20 June, 2023