UiItemsManager Class

Beta  

Controls registering of UiItemsProviders and calls the provider's methods when populating different parts of the User Interface.

Extends

  • UiItemsManager

Methods

Name Description
constructor(): UiItemsManager    

Inherited methods

Name Inherited from Description
getBackstageItems(): BackstageItem[] Static UIA_UiItemsManager Called when the application is populating the statusbar so that any registered UiItemsProvider can add status fields
getStatusBarItems(stageId: string, stageUsage: string, stageAppData?: any): CommonStatusBarItem[] Static UIA_UiItemsManager Called when the application is populating the statusbar so that any registered UiItemsProvider can add status fields
getToolbarButtonItems(stageId: string, stageUsage: string, toolbarUsage: ToolbarUsage, toolbarOrientation: ToolbarOrientation, stageAppData?: any): CommonToolbarItem[] Static UIA_UiItemsManager Called when the application is populating a toolbar so that any registered UiItemsProvider can add tool buttons that either either execute
getUiItemsProvider(providerId: string): undefined | UiItemsProvider Static UIA_UiItemsManager Retrieves a previously loaded UiItemsProvider.
getWidgets(stageId: string, stageUsage: string, location: StagePanelLocation, section?: StagePanelSection, zoneLocation?: AbstractZoneLocation, stageAppData?: any): undefined Static UIA_UiItemsManager Called when the application is populating the Stage Panels so that any registered UiItemsProvider can add widgets
register(uiProvider: UiItemsProvider, overrides?: UiItemProviderOverrides): void Static UIA_UiItemsManager Registers a UiItemsProvider with the UiItemsManager.
unregister(uiProviderId: string): void Static UIA_UiItemsManager Remove a specific UiItemsProvider from the list of available providers.

Inherited properties

Name Type Inherited from Description
hasRegisteredProviders Accessor StaticReadOnly boolean UIA_UiItemsManager Return true if there is any registered UiProvider.
onUiProviderRegisteredEvent StaticReadonly BeEvent<(ev: UiItemProviderRegisteredEventArgs) => void> UIA_UiItemsManager Event raised any time a UiProvider is registered or unregistered.
registeredProviderIds Accessor StaticReadOnly string[] UIA_UiItemsManager Return number of registered UiProvider.

Defined in

Last Updated: 20 June, 2023