DefaultNavigationWidget Class

Deprecated  in 3.6. Use BasicNavigationWidget instead

Beta  

Default Navigation Widget for zone 3. Provides standard view manipulation tools and displays registered Navigation Aids as corner item. This definition will also show a overflow button if there is not enough room to display all the toolbar buttons.

Extends

Methods

Name Description
constructor(props: DefaultNavigationProps | Readonly<DefaultNavigationProps>): DefaultNavigationWidget    
constructor(props: DefaultNavigationProps, context: any): DefaultNavigationWidget   Deprecated  
render(): Element    

Defined in

Last Updated: 20 June, 2023