BooleanEditor Class

BooleanEditor React component that is a property editor with checkbox input

Extends

Implements

Methods

Name Description
constructor(props: PropertyEditorProps | Readonly<PropertyEditorProps>): BooleanEditor    
constructor(props: PropertyEditorProps, context: any): BooleanEditor   Deprecated  
getPropertyValue(): Promise<undefined | PropertyValue>    

Properties

Name Type Description
hasFocus Accessor ReadOnly boolean    
htmlElement Accessor ReadOnly | HTMLElement    

Defined in

Last Updated: 20 June, 2023