EnumEditor Class

EnumEditor React component that is a property editor with select input

Extends

Implements

Methods

Name Description
constructor(props: PropertyEditorProps | Readonly<PropertyEditorProps>): EnumEditor    
constructor(props: PropertyEditorProps, context: any): EnumEditor   Deprecated  
getPropertyValue(): Promise<undefined | PropertyValue>    

Properties

Name Type Description
hasFocus Accessor ReadOnly boolean    
htmlElement Accessor ReadOnly | HTMLElement    

Defined in

Last Updated: 20 June, 2023