PropertyGridProps Interface

Deprecated  in 3.x. Use VirtualizedPropertyGrid instead.

Properties for PropertyGrid React component

Extends

Inherited methods

Name Inherited from Description
onPropertyContextMenu(args: PropertyGridContextMenuArgs): void Optional CommonPropertyGridProps Called to show a context menu when properties are right-clicked
onPropertyEditing(args: PropertyEditingArgs, category: PropertyCategory): void Optional CommonPropertyGridProps Callback for when properties are being edited
onPropertySelectionChanged(property: PropertyRecord): void Optional CommonPropertyGridProps Callback to property selection
onPropertyUpdated(args: PropertyUpdatedArgs, category: PropertyCategory): Promise<boolean> Optional CommonPropertyGridProps Callback for when properties are updated

Properties

Name Type Description
dataProvider IPropertyDataProvider Property data provider  

Inherited properties

Name Type Inherited from Description
actionButtonRenderers undefined | ActionButtonRenderer[] CommonPropertyGridProps Array of action button renderers.
actionButtonWidth undefined | number CommonPropertyGridProps Fixed action button column width
className undefined | string CommonPropertyGridProps Custom CSS class name
horizontalOrientationMinWidth undefined | number CommonPropertyGridProps The minimum width before the auto-switch to Vertical when the width is too narrow.
isOrientationFixed undefined | boolean CommonPropertyGridProps Indicates whether the orientation is fixed and does not auto-switch to Vertical when the width is too narrow.
isPropertyEditingEnabled undefined | boolean CommonPropertyGridProps Enables/disables property editing
isPropertyHoverEnabled undefined | boolean CommonPropertyGridProps Enables/disables property hovering effect
isPropertySelectionEnabled undefined | boolean CommonPropertyGridProps Enables/disables property selection
isPropertySelectionOnRightClickEnabled undefined | boolean CommonPropertyGridProps Enables/disables property selection with right click
itemId undefined | string CommonPropertyGridProps Optional unique identifier for item.
minLabelWidth undefined | number CommonPropertyGridProps Minimum allowed label column width, after which resizing stops
minValueWidth undefined | number CommonPropertyGridProps Minimum allowed value column width, after which resizing stops
orientation undefined | Orientation CommonPropertyGridProps Grid orientation.
propertyValueRendererManager undefined | PropertyValueRendererManager CommonPropertyGridProps Custom property value renderer manager
style undefined | CSSProperties CommonPropertyGridProps Custom CSS style properties

Defined in

Last Updated: 20 June, 2023