TileStorage Class

Beta  

Methods

Name Description
constructor(storage: ServerStorage): TileStorage    
downloadTile(iModelId: string, changesetId: string, treeId: string, contentId: string, guid?: string): Promise<Uint8Array>    
getCachedTiles(iModelId: string, _prefix: string): Promise<{ contentId: string, guid: string, treeId: string }[]>    
getDownloadConfig(iModelId: string, expiresInSeconds?: number): Promise<TransferConfig> Returns config that can be used by frontends to download tiles  
initialize(iModelId: string): Promise<void>    
isTileCached(iModelId: string, changesetId: string, treeId: string, contentId: string, guid?: string): Promise<boolean>    
uploadTile(iModelId: string, changesetId: string, treeId: string, contentId: string, content: Uint8Array, guid?: string, metadata?: Metadata): Promise<void>    

Properties

Name Type Description
storage Readonly ServerStorage    

Defined in

Last Updated: 20 June, 2023