TextureMapProps Interface

As part of a RenderMaterialAssetProps, describes how to map a RenderTexture's image to the triangles of a mesh to which the material is applied.

see RenderMaterialAssetMapsProps for the supported types of texture mappings.

extensions

Properties

Name Type Description
TextureId string The Id of the persistent Texture element defining the texture image.  
pattern_angle undefined | number Angle in degrees to rotate texture when applying; defaults to 0.0 if undefined  
pattern_flip undefined | boolean If true, flip the pattern map in V; if undefined, defaults to false  
pattern_mapping undefined | TextureMapping.Mode Mapping mode to use for the texture application; if undefined, defaults to TextureMapping.Mode.Parametric  
pattern_offset undefined | Point2dProps X, Y offset to apply to the pattern map; if undefined, defaults to {0,0}  
pattern_scale undefined | Point2dProps X, Y scale to apply to the pattern map; if undefined, defaults to {0,0}, which is almost never useful.  
pattern_scalemode undefined | TextureMapUnits Units to use when applying the scaling; if undefined, defaults to TextureMapUnits.Relative  
pattern_u_flip undefined | boolean If true, flip the pattern map in U; if undefined, defaults to false  
pattern_weight undefined | number Weight at which to combine diffuse image and color; if undefined, defaults to 1.0  

Defined in

Last Updated: 20 June, 2023