IModelTileRpcInterface Class

Extends

Methods

Name Description
getTileCacheConfig(_tokenProps: IModelRpcProps): Promise<undefined | TransferConfig>   Beta  
getTileCacheContainerUrl(_tokenProps: IModelRpcProps, _id: CloudStorageContainerDescriptor): Promise<CloudStorageContainerUrl> Returns connection information for external tile cache or an empty CloudStorageContainerUrl if no external tile cache is configured on the backend. Deprecated  Beta  
getClient(): IModelTileRpcInterface Static    

Inherited methods

Name Inherited from Description
forward<T>(parameters: IArguments): Promise<T> RpcInterface Obtains the implementation result for an RPC operation.
isVersionCompatible(backend: string, frontend: string): boolean Static RpcInterface Determines whether the backend version of an RPC interface is compatible (according to semantic versioning) with the frontend version of the interface.

Properties

Name Type Description
interfaceName StaticReadonly "IModelTileRpcInterface" The immutable name of the interface.  
interfaceVersion Static string The semantic version of the interface.  

Defined in

Last Updated: 20 June, 2023