ViewPose3d Class

The "pose" for a ViewState3d, including information about the view's Camera if it is enabled.

extensions

Extends

Methods

Name Description
constructor(view: ViewState3d): ViewPose3d Construct a pose from the specified 3d view.  

Properties

Name Type Description
camera Readonly Camera The camera parameters of the view.  

Inherited properties

Name Type Inherited from Description
cameraOn boolean ViewPose True if the camera is enabled.
center Accessor ReadOnly Point3d ViewPose Computes the center of the viewed volume.
undoTime undefined | BeTimePoint ViewPose The time at which this pose was created, if it was saved into a Viewport's undo stack.
zVec Accessor ReadOnly Vector3d ViewPose Computes the Z vector of the ViewPose.rotation matrix.

Defined in

Last Updated: 20 June, 2023