MobileHost Class

Beta  

Methods

Name Description
constructor(): MobileHost    
notifyMobileFrontend<T extends undefined>(methodName: T, ...args: Parameters<>): void Static Send a notification to the MobileApp connected to this MobileHost.  
startup(opt?: MobileHostOpts): Promise<void> Static Start the backend of a mobile app.  

Properties

Name Type Description
device Accessor StaticReadOnly MobileDevice    
isValid Accessor StaticReadOnly boolean    
onAuthAccessTokenChanged StaticReadonly BeEvent<(accessToken: undefined | string, expirationDate: undefined | string) => void>    
onEnterBackground StaticReadonly BeEvent<Listener>    
onEnterForeground StaticReadonly BeEvent<Listener>    
onMemoryWarning StaticReadonly BeEvent<Listener>    
onOrientationChanged StaticReadonly BeEvent<Listener>    
onWillTerminate StaticReadonly BeEvent<Listener>    

Defined in

Last Updated: 20 June, 2023