EnumPropertyEditor Class

Enum Property Button Group Editor registered for the "enum" type name. It uses the EnumEditor React component.

Extends

Methods

Name Description
constructor(): EnumPropertyEditor    

Inherited methods

Name Inherited from Description
applyEditorParams(_property: PropertyDescription, _record: PropertyRecord): void PropertyEditorBase  
commitValue(newValue: PropertyValue, record: PropertyRecord): Promise<AsyncValueProcessingResult> PropertyEditorBase  
validateValue(newValue: PropertyValue, record: PropertyRecord): Promise<AsyncValueProcessingResult> PropertyEditorBase  

Properties

Name Type Description
containerHandlesEnter Accessor ReadOnly boolean    
containerStopsKeydownPropagation Accessor ReadOnly boolean    
reactNode Accessor ReadOnly ReactNode    

Inherited properties

Name Type Inherited from Description
containerHandlesBlur Accessor ReadOnly boolean PropertyEditorBase  
containerHandlesEscape Accessor ReadOnly boolean PropertyEditorBase  
containerHandlesTab Accessor ReadOnly boolean PropertyEditorBase  
customDataController undefined | DataController PropertyEditorBase  

Defined in

Last Updated: 05 April, 2024