NumericInputPropertyEditor Class

Numeric Input Property Editor registered for the "number" type name and "numeric-input" editor name. It uses the NumericInputEditor React component.

Extends

Methods

Name Description
constructor(): NumericInputPropertyEditor    

Inherited methods

Name Inherited from Description
applyEditorParams(_property: PropertyDescription, _record: PropertyRecord): void PropertyEditorBase  
commitValue(newValue: PropertyValue, record: PropertyRecord): Promise<AsyncValueProcessingResult> PropertyEditorBase  
validateValue(newValue: PropertyValue, record: PropertyRecord): Promise<AsyncValueProcessingResult> PropertyEditorBase  

Properties

Name Type Description
containerHandlesEnter Accessor ReadOnly boolean    
reactNode Accessor ReadOnly ReactNode    

Inherited properties

Name Type Inherited from Description
containerHandlesBlur Accessor ReadOnly boolean PropertyEditorBase  
containerHandlesEscape Accessor ReadOnly boolean PropertyEditorBase  
containerHandlesTab Accessor ReadOnly boolean PropertyEditorBase  
containerStopsKeydownPropagation Accessor ReadOnly boolean PropertyEditorBase  
customDataController undefined | DataController PropertyEditorBase  

Defined in

Last Updated: 21 March, 2024