TextareaPropertyEditor Class

Textarea Property Editor registered for the "text" and "string" type names and "multi-line" editor name. It uses the TextareaEditor React component.

Extends

Methods

Name Description
constructor(): TextareaPropertyEditor    

Inherited methods

Name Inherited from Description
applyEditorParams(_property: PropertyDescription, _record: PropertyRecord): void PropertyEditorBase  
commitValue(newValue: PropertyValue, record: PropertyRecord): Promise<AsyncValueProcessingResult> PropertyEditorBase  
validateValue(newValue: PropertyValue, record: PropertyRecord): Promise<AsyncValueProcessingResult> PropertyEditorBase  

Properties

Name Type Description
containerHandlesBlur Accessor ReadOnly boolean    
containerHandlesEnter Accessor ReadOnly boolean    
containerHandlesTab Accessor ReadOnly boolean    
reactNode Accessor ReadOnly ReactNode    

Inherited properties

Name Type Inherited from Description
containerHandlesEscape Accessor ReadOnly boolean PropertyEditorBase  
containerStopsKeydownPropagation Accessor ReadOnly boolean PropertyEditorBase  
customDataController undefined | DataController PropertyEditorBase  

Defined in

Last Updated: 05 April, 2024