Workspace Namespace
Interface
Name | Description |
---|---|
Workspace.SettingsDictionaryLoaded | Arguments supplied to onSettingsDictionaryLoadedFn for every SettingsDictionary that is loaded from a WorkspaceDb. |
Type alias
Name | Description |
---|---|
Workspace.DbListFilter | In arguments supplied to getWorkspaceDbs and resolveWorkspaceDbSetting, an optional function used to exclude some |
Workspace.DbListOrSettingName | Either an array of WorkspaceDbCloudProps or the name of a Setting that resolves to an array of WorkspaceDbCloudProps. |
Function
Name | Description |
---|---|
Workspace.exceptionDiagnosticFn | A function invoked to handle exceptions produced while loading workspace data. |
Workspace.getBlobResource | Searches a list of WorkspaceDbs for a blob resource of a given name. |
Workspace.getStringResource | Searches a list of WorkspaceDbs for a string resource of a given name. |
Workspace.onSettingsDictionaryLoadedFn | A function invoked each time any SettingsDictionary is loaded from a WorkspaceDb. |
Workspace.queryResources | Query a list of WorkspaceDbs to find resources of a particular type with names matching a specified pattern. |
Defined in
Workspace Interface
Settings and resources that customize an application for the current session. See the learning article for a detailed overiew and examples.
Methods
Name | Description | |
---|---|---|
getCloudCache(): CloudSqlite.CloudCache | Get the cloud cache for cloud-based WorkspaceContainers. | |
getContainer(props: GetWorkspaceContainerArgs): WorkspaceContainer | Get a WorkspaceContainer with a supplied access token. | |
getContainerAsync(props: WorkspaceContainerProps): Promise<WorkspaceContainer> | Obtain the WorkspaceContainer specified by props . |
|
getWorkspaceDb(props: WorkspaceDbCloudProps): Promise<WorkspaceDb> | Get a single WorkspaceDb. | |
getWorkspaceDbs(args: Workspace.DbListOrSettingName & { filter?: Workspace.DbListFilter, problems?: WorkspaceDbLoadError[] }): Promise<WorkspaceDb[]> | Get a sorted array of WorkspaceDbs that can be used to query or load resources. | |
loadSettingsDictionary(props: WorkspaceDbSettingsProps | WorkspaceDbSettingsProps[], problems?: WorkspaceDbLoadError[]): Promise<void> | Load a SettingsDictionary from the specified WorkspaceDb and add it to this workspace's current Settings. | |
resolveWorkspaceDbSetting(settingName: string, filter?: Workspace.DbListFilter): WorkspaceDbCloudProps[] | Resolve the value of all Settings from this workspace with the supplied settingName into an array of WorkspaceDbCloudProps |
Properties
Name | Type | Description | |
---|---|---|---|
settings Readonly | Settings | The current Settings for this Workspace |
Defined in
Last Updated: 06 September, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.