RenderSchedule.ColorEntry Class

A timeline entry controlling the color of the affected geometry.

Extends

Methods

Name Description
constructor(props: RenderSchedule.ColorEntryProps): RenderSchedule.ColorEntry    
compareTo(other: RenderSchedule.ColorEntry): number    
toJSON(): RenderSchedule.ColorEntryProps    

Inherited methods

Name Inherited from Description
equals(other: RenderSchedule.TimelineEntry): boolean RenderSchedule.TimelineEntry  

Properties

Name Type Description
value Readonly undefined | RgbColor If defined, the color in which to draw the geometry.  

Inherited properties

Name Type Inherited from Description
interpolation Readonly RenderSchedule.Interpolation RenderSchedule.TimelineEntry How to interpolate from this entry to the next entry in the timeline.
time Readonly number RenderSchedule.TimelineEntry The time point in seconds in the Unix Epoch.

Defined in

Last Updated: 16 April, 2024