IModelConnection.Categories Namespace

Interface

Name Description
IModelConnection.Categories.IModelConnection.Categories.CategoryInfo A subset of the information describing a Category, supplied by IModelConnection.Categories.getCategoryInfo.
IModelConnection.Categories.IModelConnection.Categories.SubCategoryInfo A subset of the information describing a SubCategory, supplied by IModelConnection.Categories.getCategoryInfo

Defined in

IModelConnection.Categories Class

Provides access to information about the Category's stored in an IModelConnection. This information is cached internally so that repeated requests need not query the backend.

@see IModelConnection.categories for the categories associated with a specific iModel.

Methods

Name Description
getCategoryInfo(categoryIds: Iterable<string>): Promise<Map<string, IModelConnection.Categories.IModelConnection.Categories.CategoryInfo>> Obtain information about one or more Category's.  
getSubCategoryInfo(args: { category: string, subCategories: Iterable<string> }): Promise<Map<string, IModelConnection.Categories.IModelConnection.Categories.SubCategoryInfo>> Obtain information about one or more SubCategory's belonging to the specified Category.  

Defined in

Last Updated: 16 April, 2024